Certyfikat do szyfrowania do GIIF jest już nieaktualny
Występowanie
Platforma: wszystkie
Oprogramowanie Unizeto: Auctor IC 1.6.4
Objawy
Program Auctor IC szyfruje dane do GIIF starym certyfikatem.
Rozwiązanie
Ściągnąć nowy certyfikat dostępny na naszym serwisie www (pobierz) i zastąpić nim istniejący certyfikat sigiif.cer znajdujący się w katalogu "C:\Program Files\Unizeto\Auctor IC\Certyfikaty\GIIF\" (w przypadku zainstalowania aplikacji Auctor IC w domyślnym folderze). Nowa wersja oprogramowania Auctor IC 2.0 posiada mechanizm automatycznej aktualizacji certyfikatu do szyfrowania do GIIF.
Problem z instalacją czytników
Występowanie
Platforma: Windows 98
Objawy
Po kliknięciu przycisku:
pojawiają się kolejno komunikaty:
Rozwiązanie (dla czytników CardMan 2020 i CardMan 6020)
1. Najpierw uruchamiamy dwa pliki:
scbase.exe,
Smclib.exe.
Pliki znajdują się na dostarczonej płycie CD w folderze „...\Drivers\CmSetup\SCBase":
2. Potem restartujemy komputer.
3. Instalujemy sterowniki do czytników, wykonując po kolei kroki:
w menu „Start" -> „Ustawienia" -> „Panel sterowania" klikamy ikonę „System",
w zakładce „Menedżer urządzeń" wybieramy pozycję „Smart Card Readers", a następnie „CardMan 2020" i klikamy przycisk „Właściwości",
w zakładce „Sterownik" klikamy przycisk „Aktualizuj sterownik",
potem w kolejno pojawiających się oknach wybieramy opcje przedstawione na poniższych ilustracjach:
w poniższym oknie klikamy przycisk „Przeglądaj",
zgodnie z przedstawioną poniżej ścieżką wskazujemy na płycie CD AUCTOR IC plik o nazwie: cmeu0wdm.inf .
4. To samo robimy z drugim czytnikiem(CardMan 6020), po czym restartujemy komputer.
Po uruchomieniu profilu powszechnego pojawia się następujący komunikat:
Przyczyna
Nie zainstalowano pakietu „Podpis zwykły” albo podczas jego instalacji pojawił się problem.
Rozwiązanie
Żeby doinstalować pakiet „Podpis zwykły”, uruchomić należy standardową instalację oprogramowania z dostarczonej płyty CD. Instalator dołączy wszystkie brakujące aplikacje.
Jeśli pakiet „Podpis zwykły” jest już zainstalowany, należy go odinstalować i zainstalować ponownie. Żeby sprawdzić, czy pakiet jest zainstalowany, uruchamiamy kolejno:
„Mój komputer”,
„Panel sterowania”,
„Dodaj programy” lub „Usuń programy”.
Następnie sprawdzamy, czy na wyświetlonej liście widnieje pozycja: „Podpis elektroniczny zwykły”. Jeśli tak, odinstalowujemy go i instalujemy ponownie zgodnie z powyższym opisem.
Nie można zamknąć okna kończącego instalację pakietu Auctor IC
W aplikacji proCertum CardManager nie odblokowano kodu PIN.
Rozwiązanie
Nadajemy nowy PIN przy użyciu aplikacji proCertum CardManager.
W aplikacji Auctor IC nie można podpisać elektronicznie dokumentu przyciskiem "Podpisz dokument"
Występowanie
Platforma: Windows 98/Me/NT/2000/XP
Oprogramowanie Unizeto: Auctor IC (AUCTOR IC 1.6/1.6.1)
Objawy
Podczas próby podpisania dokumentu pojawia się komunikat:
Przyczyna
Aplikację zainstalowano w innym profilu użytkownika niż użytkowany właśnie profil.
Rozwiązanie
Aplikacja powinna być instalowana w profilu, w którym będzie używana. Jeżeli profilem tym nie jest profil administratora, na czas instalacji użytkownik musi mieć prawa administratora.
Błąd podczas podpisywania pliku przyciskiem "Podpisz dokument"
Występowanie
Platforma: Windows 98/Me/NT/2000/XP
Oprogramowanie Unizeto: Autor IC (AUCTOR IC 1.6/1.6.1)
Objawy
Po wyborze certyfikatu do podpisu pojawia się komunikat:
Ewentualne przyczyny
1. Nie zaznaczono checkboxu "Podpis kwalifikowany" w oknie „Auctor IC – Podpisywanie dokumentów elektronicznych" (w przypadku składania podpisu bezpiecznego),
2. wybrano niewłaściwą politykę podpisu (dla podpisu bezpiecznego jest to cck002.spol),
3. nie zainstalowano zaświadczeń certyfikacyjnych (rootów) urzędów (CZiC Centrast SA, Unizeto CERTUM CCK ‑ CA oraz CERTUM QCA). Aby sprawdzić, czy mamy zainstalowane odpowiednie zaświadczenia certyfikacyjne, w przypadku przeglądarki Internet Explorer klikamy kolejno:
„Narzędzia”;
„Opcje internetowe”;
zakładkę „Zawartość”;
„Certyfikaty”;
zakładkę „Pośrednie urzędy certyfikacji”;
W wyświetlonym oknie sprawdzamy, czy na liście jest pozycja „Unizeto CERTUM‑CCK‑CA”.
Sprawdzamy również, czy na liście jest pozycja „CERTUM QCA”.
W zakładce „Zaufane główne urzędy certyfikacji" sprawdzamy, czy na liście jest pozycja „CZiC Centrast SA”.
4. Niepoprawnie złożono ścieżkę certyfikacji.
Rozwiązania
Ad.1. Przy składaniu podpisu bezpiecznego checkbox "Kwalifikowany podpis" musi być zaznaczony,
Ad.2. polityka podpisu musi odpowiadać certyfikatowi, który ma zostać wykorzystany do złożenia podpisu:
cck002.spol – umożliwia złożenie podpisu bezpiecznego,
cck006.spol – umożliwia złożenie podpisu przy wykorzystaniu certyfikatu powszechnego CERTUM,
cck008a.spol – umożliwia złożenie podpisu bezpiecznego testowego.
Ad.3. należy zainstalować certyfikaty urzędów dostępne pod adresem:
Ad.4. usunąć certyfikaty urzędów z magazynów certyfikatów i zainstalować je ponownie z wyżej podanych adresów. Certyfikaty można usunąć w oknach przedstawionych powyżej w „Przyczynach” punkt3.
Zamiast opisu właściciela certyfikatu kwalifikowanego pojawia się napis PL
Występowanie
Platforma: Windows 98
Oprogramowanie Unizeto: proCertum CardManager wersja niższa od 2.1.0.24 (AUCTOR IC 1.6)
Objawy
W aplikacji proCertum CardManager w polu „Właściciel certyfikatu" widoczny jest tylko opis „PL”. To samo pojawia się w każdym oknie wyboru certyfikatu w różnych aplikacjach i oknach systemowych.
Przyczyna
Windows 98 nie obsługuje kodowania UTF-8, a w takim właśnie formacie zapisane są dane opisujące właściciela w certyfikacie kwalifikowanym (wymóg Rozporządzenia Rady Ministrów z dnia 7 sierpnia 2002 r., załącznik nr 2, pkt 1.1.6 „Właściciel certyfikatu (Subject)").
Rozwiązanie
Update oprogramowania m.in. uaktualnia plik proCertumCardManager.exe do wersji 2.1.0.24. Po aktualizacji aplikacja proCertum CardManager poprawnie wyświetla właściciela certyfikatu.
W magazynach systemu operacyjnego mimo to nadal widoczny jest tylko napis „PL".
Nie można zarejestrować certyfikatu powszechnego w aplikacji proCertum CardManager
Brak przycisku „Rejestruj certyfikaty" w profilu powszechnym aplikacji proCertum CardManager
Przyczyna
Nie zarejestrowano jednej z bibliotek.
Rozwiązanie
Należy zaimportować plik rejestru cspSig.reg znajdujący się na stronach z update'em.
GIIF nie przyjmuje niewłaściwie zaszyfrowanych danych. Informacje o przyczynie odrzucenia danych można uzyskać telefonicznie w GIIF
Występowanie
Platforma: Windows 98/Me/NT/2000/XP
Oprogramowanie Unizeto: Autor IC wersja niższa od 1.6.2.16 (AUCTOR IC 1.6.1)
Objawy
Przesyłki wysyłane do GIIF poprzez opcje w oprogramowaniach niektórych firm trzecich nie pojawiają się na stronie GIIF-u, a w przypadku przesyłania przesyłek przez stronę www.giif.mofnet.gov.pl/giif otrzymują one status „niepoprawny".
Przyczyna
Certyfikat do szyfrowania wystawiony przez GIIF jest niewłaściwy. Można to sprawdzić dwa razy klikając lewym przyciskiem myszy plik sigiif.cer zawierający certyfikat, który znajduje się folderze: „C:\Program Files\Unizeto\Auctor IC\Certyfikaty\GIIF\" (w przypadku zainstalowania aplikacji Autor IC w domyślnym folderze). Informacja, która pojawi się w zakładce „Ogólne"„Wystawiony dla", zawierać będzie informację: „Test SIGIIF CA".
Rozwiązanie
Należy podmienić plik certyfikatu na plik zawierający poprawny certyfikat. Po podmianie pliku okno z właściwościami certyfikatu i zakładką „Ścieżka certyfikacji" powinno wyglądać następująco:
System jest niestabilny po włożeniu kart do czytników w Windows XP, a zwłaszcza po zainstalowaniu dodatku Service Pack 2
Występowanie
Platforma: Windows XP
Oprogramowanie Unizeto: Autor IC wszystkie wersje
Objawy
Podłączenie czytników z włożonymi do nich kartami mikroprocesorowymi lub włożenie tych kart do podłączonych czytników po zainstalowaniu Service Pack 2 powoduje zawieszanie się komputera lub jego ciągłe restarty. Z systemu można znów korzystać po wyciągnięciu obu kart z czytników i ponownym jego uruchomieniu.
Przyczyna
Problem wynika z wadliwego działania sterowników czytników kart dostarczonych z systemem Windows XP. Nie ujawnia się na wszystkich stacjach roboczych, występuje częściej po instalacji dodatku Service Pack 2.
Rozwiązanie
Przed uruchomieniem komputera z systemem operacyjnym Windows XP z zainstalowanym dodatkiem Service Pack 2 należy koniecznie wyciągnąć obie karty z czytników (również „małą" kartę SAM). Po uruchomieniu systemu operacyjnego należy włożyć płytę instalacyjną z pakietem AUCTOR IC i po jej uruchomieniu kliknąć przycisk:
po wskazaniu czytnika kart (domyślnie będzie to CardMan 2020) użytkownik kliknąć musi opcję „Instaluj sterownik",
po zainstalowaniu czytników i ponownym uruchomieniu systemu Windows można umieścić obie karty w czytnikach.
Jak przygotować karty do użytku? (nadawanie numerów PIN)
Przed pierwszym użyciem karty z certyfikatem do podpisu elektronicznego należy wykonać następujące czynności:
zainstalować zestaw Auctor lub Suscriptor (aplikacje i czytniki),
włożyć kartę z certyfikatem do czytnika,
uruchomić aplikację proCertum CardManager,
kliknąć przycisk „Czytaj kartę”.
Żeby nadać numer PIN podpisowi kwalifikowanemu, należy:
kliknąć zakładkę „Profil bezpieczny” (dostęp do profilu bezpiecznego karty kryptograficznej możliwy jest tylko i wyłącznie z modułem uwierzytelniającym podłączonym do stacji roboczej),
kliknąć przycisk „Nowy PIN”,
podać PUK dla profilu bezpiecznego, który został dostarczony na bezpiecznym wydruku z nagłówkiem: CERTUM – Powszechne Centrum Certyfikacji. Podczas wprowadzania kodu PUK należy zwrócić szczególną uwagę na wielkość wprowadzonych znaków.
UWAGA
Trzykrotne podanie błędnego kodu PUK trwale blokuje profil karty.
wpisać PIN, którego będzie można używać do składania podpisu kwalifikowanego. Kod PIN może się składać tylko i wyłącznie z cyfr (od 4 do 8),
ponownie wpisać PIN w oknie „Potwierdź nowy PIN”,
nacisnąć „OK".
Żeby nadać numer PIN podpisowi niekwalifikowanemu ( powszechnemu), należy:
kliknąć zakładkę „Profil zwykły,
nacisnąć przycisk „Nowy PIN”,
podać PUK dla profilu zwykłego, który został dostarczony na bezpiecznym wydruku z nagłówkiem: Unizeto Certum – Centrum Certyfikacji POWSZECHNE. Podczas wprowadzania kodu PUK należy zwrócić szczególną uwagę na wielkość wprowadzonych znaków.
UWAGA
Trzykrotne podanie błędnego kodu PUK trwale blokuje profil karty.
wpisać PIN, który będzie można używać do składania podpisu niekwalifikowanego (powszechnego). Kod PIN może się składać tylko i wyłącznie z cyfr (od 4 do 8),
ponownie wpisać PIN w oknie „Potwierdź nowy PIN”,
nacisnąć „OK".
Certyfikat kwalifikowany nie jest widoczny podczas uwierzytelniania się na stronie www GIIF
Występowanie
Platforma: Windows 98/Me/NT/2000/XP
Objawy
Lista certyfikatów pojawiająca się podczas uwierzytelniania na stronie www GIIF jest pusta.
Przyczyna
Certyfikat kwalifikowany nie został zarejestrowany w aplikacji proCertum CardManager.
Rozwiązanie
Należy zarejestrować certyfikat kwalifikowany w aplikacji proCertum CardManager, używając do tego przycisku „Rejestruj certyfikaty" znajdującego się w profilu bezpiecznym.
Podczas nadawania nowego PIN-u nie można go wprowadzić znaki nie pojawiają się w okienku
Choć wpisuje się znaki z klawiatury, na ekranie nic się nie pojawia.
Przyczyna
Użytkownik próbuje wprowadzić znaki inne niż cyfry.
Rozwiązanie
W profilu bezpiecznym kod PIN musi być złożony z co najmniej czterech, a najwyżej ośmiu cyfr. Należy więc wprowadzić wybraną kombinację cyfr.
Czytniki nie działają poprawnie, mimo że ich instalacja przebiegła pomyślnie
Występowanie
Platforma: Windows 98
Objawy
Czytniki są na liście zainstalowanych urządzeń, a aplikacja, np. proCertum CardManager, komunikuje, że ich nie ma.
Przyczyna
Podczas uruchamiania systemu serwer PC/SC załadował się wcześniej niż sterowniki czytników.
Rozwiązanie
Zrestartować komputer.
Przy podpisywaniu i szyfrowaniu raportu do GIIF pojawia się komunikat z informacją że certyfikat do szyfrowania jest nieaktualny pomimo tego że jest ważny.
Występowanie
Platforma: Windows 98/Me/NT/2000/XP
Oprogramowanie Unizeto: Auctor IC 2.0
Objawy
Po naciśnięciu przycisku 'Podpisz i szyfruj raport dla GIIF' lub 'Zaszyfruj raport dla GIIF' w zakładce GIIF pojawia się poniższy komunikat.
Przyczyna
Ustawiony jest źle format daty.
Rozwiązanie
Przestawić format daty krótkiej na rrrr-mm-dd. Mozna tego dokonać w Panelu Sterowania wybierająć ikonę 'Opcje regionalne i językowe' tam następnie w zakładce 'data' należy dokonać odpowiednich zmian. W przypadku Windows XP należy najpierw kliknąć przycisk 'dostosuj' w zakładce 'Opcje regionalne'.
Przy podpisywaniu i szyfrowaniu raportu do GIIF pojawia się komunikat z informacją, że nie udało się uzyskać aktualnego certyfikatu GIIF.
Występowanie
Platforma: Windows 98/Me/NT/2000/XP
Oprogramowanie Unizeto: Auctor IC 2.0
Objawy
Po naciśnięciu przycisku 'Podpisz i szyfruj raport dla GIIF' lub 'Zaszyfruj raport dla GIIF' w zakładce GIIF pojawia się poniższy komunikat.
Przyczyna
Ustawiony jest źle format daty.
Rozwiązanie
Przestawić format daty krótkiej na rrrr-mm-dd i separator daty na -. Mozna tego dokonać w Panelu Sterowania wybierając ikonę 'Opcje regionalne i językowe' tam następnie w zakładce 'data' należy dokonać odpowiednich zmian. W przypadku Windows XP naleźy najpierw kliknąć przycisk 'dostosuj' w zakładce 'Opcje regionalne'.
Problem z uruchomieniem aplikacji proCertum SecureSignVer