Po uruchomieniu profilu powszechnego pojawia się następujący komunikat:
Przyczyna
Nie zainstalowano pakietu „Podpis powszechny” albo podczas jego instalacji pojawił się problem.
Rozwiązanie
Żeby doinstalować pakiet „Podpis powszechny", uruchomić należy standardową instalację oprogramowania z dostarczonej płyty CD. Instalator dołączy wszystkie brakujące aplikacje.
Jeśli pakiet „Podpis powszechny" jest już zainstalowany, należy go odinstalować i zainstalować ponownie. Żeby sprawdzić, czy pakiet jest zainstalowany, uruchamiamy kolejno:
„Mój komputer”,
„Panel sterowania”,
„Dodaj programy” lub „Usuń programy”.
Następnie sprawdzamy, czy na wyświetlonej liście widnieje pozycja: „Podpis elektroniczny powszechny". Jeśli tak, odinstalowujemy go i instalujemy ponownie zgodnie z powyższym opisem.
W aplikacji proCertum CardManager nie odblokowano kodu PIN.
Rozwiązanie
Nadajemy nowy PIN przy użyciu aplikacji proCertum CardManager.
Zamiast opisu właściciela certyfikatu kwalifikowanego pojawia się napis PL
Występowanie
Platforma: Windows 98
Oprogramowanie Unizeto: proCertum CardManager wersja niższa od 2.1.0.24 (SUSCRIPTOR 1.4.1)
Objawy
W aplikacji proCertum CardManager w polu „Właściciel certyfikatu" widoczny jest tylko opis „PL”. To samo pojawia się w każdym oknie wyboru certyfikatu w różnych aplikacjach i oknach systemowych.
Przyczyna
Windows 98 nie obsługuje kodowania UTF-8, a w takim właśnie formacie zapisane są dane opisujące właściciela w certyfikacie kwalifikowanym (wymóg Rozporządzenia Rady Ministrów z dnia 7 sierpnia 2002 r., załącznik nr 2, pkt 1.1.6 „Właściciel certyfikatu (Subject)").
Rozwiązanie
Update oprogramowania m.in. uaktualnia plik proCertumCardManager.exe do wersji 2.1.0.24. Po aktualizacji aplikacja proCertum CardManager poprawnie wyświetla właściciela certyfikatu.
W magazynach systemu operacyjnego mimo to nadal widoczny jest tylko napis „PL".
Nie można zarejestrować certyfikatu powszechnego w aplikacji proCertum CardManager
Brak przycisku „Rejestruj certyfikaty" w profilu powszechnym aplikacji proCertum CardManager
Przyczyna
Nie zarejestrowano jednej z bibliotek.
Rozwiązanie
Należy zaimportować plik rejestru cspSig.reg znajdujący się na stronach z update'em.
System jest niestabilny po włożeniu kart do czytników w Windows XP, a zwłaszcza po zainstalowaniu dodatku Service Pack 2
Występowanie
Platforma: Windows XP
Oprogramowanie Unizeto: Autor IC wszystkie wersje
Objawy
Podłączenie czytników z włożonymi do nich kartami mikroprocesorowymi lub włożenie tych kart do podłączonych czytników po zainstalowaniu Service Pack 2 powoduje zawieszanie się komputera lub jego ciągłe restarty. Z systemu można znów korzystać po wyciągnięciu obu kart z czytników i ponownym jego uruchomieniu.
Przyczyna
Problem wynika z wadliwego działania sterowników czytników kart dostarczonych z systemem Windows XP. Nie ujawnia się na wszystkich stacjach roboczych, występuje częściej po instalacji dodatku Service Pack 2.
Rozwiązanie
Przed uruchomieniem komputera z systemem operacyjnym Windows XP z zainstalowanym dodatkiem Service Pack 2 należy koniecznie wyciągnąć obie karty z czytników (również „małą" kartę SAM). Po uruchomieniu systemu operacyjnego należy włożyć płytę instalacyjną z pakietem AUCTOR IC i po jej uruchomieniu kliknąć przycisk:
po wskazaniu czytnika kart (domyślnie będzie to CardMan 2020) użytkownik kliknąć musi opcję „Instaluj sterownik",
po zainstalowaniu czytników i ponownym uruchomieniu systemu Windows można umieścić obie karty w czytnikach.
Jak przygotować karty do użytku? (nadawanie numerów PIN)
Przed pierwszym użyciem karty z certyfikatem do podpisu elektronicznego należy wykonać następujące czynności:
zainstalować zestaw Auctor lub Suscriptor (aplikacje i czytniki),
włożyć kartę z certyfikatem do czytnika,
uruchomić aplikację proCertum CardManager,
kliknąć przycisk „Czytaj kartę”.
Żeby nadać numer PIN podpisowi kwalifikowanemu, należy:
kliknąć zakładkę „Profil bezpieczny” (dostęp do profilu bezpiecznego karty kryptograficznej możliwy jest tylko i wyłącznie z modułem uwierzytelniającym podłączonym do stacji roboczej),
kliknąć przycisk „Nowy PIN”,
podać kod PUK dla profilu bezpiecznego, który uzyskiwany jest w trakcie procesu pobierania certyfikatu kwalifikowanego na kartę. Podczas wprowadzania kodu PUK należy zwrócić szczególną uwagę na wielkość wprowadzonych znaków.
UWAGA
Trzykrotne podanie błędnego kodu PUK trwale blokuje profil karty.
wpisać PIN, którego będzie można używać do składania podpisu kwalifikowanego. Kod PIN może się składać tylko i wyłącznie z cyfr (od 4 do 8),
ponownie wpisać PIN w oknie „Potwierdź nowy PIN”,
nacisnąć „OK".
Żeby nadać numer PIN podpisowi niekwalifikowanemu (powszechnemu), należy:
kliknąć zakładkę „Profil zwykły”,
nacisnąć przycisk „Inicjalizuj profil”,
podać kod PUK dla profilu zwykłego, który jest definiowany przez użytkownika. Kod PUK może mieć długość od 4 do 8 znaków. Zaleca się, aby kod PUK składał się ze standardowych znaków takich jak cyfry oraz duże i małe litery alfabetu angielskiego,
ponownie wpisać kod PUK w oknie „Potwierdź nowy PUK”,
wpisać PIN, który będzie można używać do składania podpisu niekwalifikowanego (powszechnego). Kod PIN może się składać tylko i wyłącznie z cyfr (od 4 do 8),
ponownie wpisać PIN w oknie „Potwierdź nowy PIN”,
nacisnąć „OK".
Podczas nadawania nowego PIN-u nie można go wprowadzić, znaki nie pojawiają się w okienku